LED con luce fioca scheda illuminazione carrozza

Tutto ciò che è elettricità applicata al fermodellismo.

Moderatori: liftman, roy67

Avatar utente
iname1030
Socio GAS TT
Messaggi: 26
Iscritto il: mercoledì 19 aprile 2017, 20:05
Nome: Adriano
Regione: Lombardia
Città: Brescia
Stato: Non connesso

LED con luce fioca scheda illuminazione carrozza

Messaggio da iname1030 »

La scheda di illuminazione della quarta carrozza dell' elettrotreno (Arlecchino Acme) ha iniziato ad avere tre dei quattro LED che emettono luce fioca ed uno è quasi spento mentre quelli delle altre tre carrozze funzionano tutti bene. Provata separatamente il difetto permane. Sembrerebbe che uno o piu' componenti siano da sostituire, non sono esperto in circuiti e purtropo non so identificare il tipo di guasto.
Allego un paio di immagini che meglio descrivono lo schema con i suoi componenti. Grazie per qualsiasi info.
Allegati
1Alt.jpg
2s.jpg


Avatar utente
MrPatato76
Socio GAS TT
Messaggi: 4563
Iscritto il: lunedì 27 agosto 2012, 11:14
Nome: Roberto
Regione: Lombardia
Città: Nova Milanese
Stato: Non connesso

Re: LED con luce fioca scheda illuminazione carrozza

Messaggio da MrPatato76 »

Provata separata cosa vuol dire?
Hai alimentato solo la carrozza? O hai scollegato la scheda e alimentata direttamente?
Potrebbero essere le lamelle che prendono corrente (se presenti) dalle ruote che si sono sporcate od ossidate.
O , se la scheda viene alimentata da condotta passante, potrebbe essere il connettore sporco o ossidato.
Un calo di luminosità indica un calo di tensione ai leds, tipicamente provocato da cattiva captazione/conduzione.
In caso di avaria o bruciatura, non si accenderebbero proprio.
Acme o Almrose dovrebbero avere comunque il ricambio scheda.
Roberto - "...il bambino che vede un treno lo saluta con la manina, questo non succede con un auto!" (Cit.) - Ciao Roberto
Avatar utente
iname1030
Socio GAS TT
Messaggi: 26
Iscritto il: mercoledì 19 aprile 2017, 20:05
Nome: Adriano
Regione: Lombardia
Città: Brescia
Stato: Non connesso

Re: LED con luce fioca scheda illuminazione carrozza

Messaggio da iname1030 »

Ho scollegato la scheda e l'ho alimentatata direttamente, i cavi R-N-B-V-G sono saldati per test allo zoccolo .
Per Acme: sul foglio istruzioni vi sono le schede ma nessun ricambio per ETR è elencato sul loro sito ( purtroppo contattarli è tempo sprecato, non perso).
Avatar utente
roy67
Socio GAS TT
Messaggi: 6397
Iscritto il: domenica 27 gennaio 2013, 8:13
Nome: Roberto
Regione: Emilia Romagna
Città: Parma
Ruolo: Moderatore
Stato: Non connesso

Re: LED con luce fioca scheda illuminazione carrozza

Messaggio da roy67 »

Devi fare misurazioni con tester.
Verificare, innanzi tutto, che tensione arriva e paragonare, a parità di alimentazione, una carrozza ben funzionante e quella difettosa.

Via web si fa molta fatica a capire cosa succede sul circuito.

Quindi:
Apri un altra carrozza e misura la tensione che arriva al PCB. Fai la stessa misurazione sulla carrozza difettosa.
Uguale?
Differente?

Ora fai la stessa misurazione, misurando però l'assorbimento elettrico (milliampere).

Poi misuri gli Ohm sulle resistenze senza alimentazione.... E così via.
Ciao. Roberto Alinovi - L'uomo non teme ciò che in lui non c'è. (Hermann Hesse)
Avatar utente
iname1030
Socio GAS TT
Messaggi: 26
Iscritto il: mercoledì 19 aprile 2017, 20:05
Nome: Adriano
Regione: Lombardia
Città: Brescia
Stato: Non connesso

Re: LED con luce fioca scheda illuminazione carrozza

Messaggio da iname1030 »

In effetti sentendo oggi Almrose hanno preparato da tempo il prototipo di un kit-illuminazione, che potra essere messo in produzione forse a breve. Si tratterà poi di vedere come è implementato il kit ( scheda singola per ogni carrozza spero) . Ma per ora mi interesserebbe capire cosa non va, ci vorrà un po di tempo ma quando possibile eseguiro le misure. Per ora grazie a tutti.
Avatar utente
iname1030
Socio GAS TT
Messaggi: 26
Iscritto il: mercoledì 19 aprile 2017, 20:05
Nome: Adriano
Regione: Lombardia
Città: Brescia
Stato: Non connesso

Re: LED con luce fioca scheda illuminazione carrozza

Messaggio da iname1030 »

Ho rilevato per le carrozze funzionanti:
-tensione=19V
-asssorbimento=1,9 mA
-R1=99 Ohm; R2=30 Ohm; R3= 10 Ohm

Invece per quella con i LED malfunzionanti:
-tensione in Cn1-Cn2-Cn3 =19V mentre in Cn4=0 e/o 2V
-asssorbimento= 0,3 mA
-R1=99 Ohm; R2=30 Ohm; R3= 10 Ohm

Qualche informazione magari utile:
Cn4 è lo spinotto a 5 poli a destra nell'immagine ed è l'ultimo del treno sulla carrozza 4; se non completamente collegato con tutte e quattro le carrozze e con tutte e quattro le schede di illuminazione il treno non riceve corrente; Cn1 e Cn2 hanno cavi Rossi-Neri provenienti dalle rotaie; le condotte passanti Cn3 e Cn4 hanno tensione nei cavi Giallo-Verde.
Avatar utente
roy67
Socio GAS TT
Messaggi: 6397
Iscritto il: domenica 27 gennaio 2013, 8:13
Nome: Roberto
Regione: Emilia Romagna
Città: Parma
Ruolo: Moderatore
Stato: Non connesso

Re: LED con luce fioca scheda illuminazione carrozza

Messaggio da roy67 »

Quindi, mi sembra di capire che su CN4 ci siano già "solo" 2 V.
CN4 è un connettore che porta tensione dai binari nella condotta passante.

E' chiaro che fra CN3 e CN4 c'è un assorbimento anomalo.
Misurato agli ingressi fra 19V e 2V.
L'assorbimento, in mA, è relativo considerata la caduta drammatica di tensione.

Ora bisognerebbe essere in possesso dello schema elettrico del PCB.. Ma a lume di naso mi scappa detto che "U1" è stanco...
Mi sembra un transistor che deve comandare l'accesione se presente un decoder....
Ciao. Roberto Alinovi - L'uomo non teme ciò che in lui non c'è. (Hermann Hesse)
Avatar utente
iname1030
Socio GAS TT
Messaggi: 26
Iscritto il: mercoledì 19 aprile 2017, 20:05
Nome: Adriano
Regione: Lombardia
Città: Brescia
Stato: Non connesso

Re: LED con luce fioca scheda illuminazione carrozza

Messaggio da iname1030 »

Si, il decoder è presente. Volendo tentare la sostituzione il transistor è marcato "L2 ṣ 47" ma non trovo corrispondenze in rete, che caratteristiche dovrebbe avere ?
Allegati
PIC002.JPG
Avatar utente
roy67
Socio GAS TT
Messaggi: 6397
Iscritto il: domenica 27 gennaio 2013, 8:13
Nome: Roberto
Regione: Emilia Romagna
Città: Parma
Ruolo: Moderatore
Stato: Non connesso

Re: LED con luce fioca scheda illuminazione carrozza

Messaggio da roy67 »

Quello è il problema.
Dovrai verificare tu i 2 transistor (sempre che di transistor di tratti, ma 547 è un indizio "forte") contenuti nell'involucro, se PNP o NPN.

Purtroppo sono anni che i costruttori si "autosiglano" i componenti, fatti costruire appositamente su loro "specifica".
Non c'è nulla di altro da fare.

Studi il componente (ormai compromesso), quindi difficoltoso da capire.
Verifichi un altra carrozza con lo stesso componente, per paragone.
Oppure acquisti un nuovo PCB di ricambio.

Pensa che le stesse parole le scrissi su un altro forum nel 2012.... :wink:
Ciao. Roberto Alinovi - L'uomo non teme ciò che in lui non c'è. (Hermann Hesse)
Avatar utente
liftman
Socio GAS TT
Messaggi: 7484
Iscritto il: domenica 29 gennaio 2012, 14:40
Nome: Rolando
Regione: Liguria
Città: La Spezia
Ruolo: Moderatore
Stato: Non connesso

Re: LED con luce fioca scheda illuminazione carrozza

Messaggio da liftman »

un transistor a 6 piedini? 😯😯😯😯
Ciao! Rolando
Avatar utente
iname1030
Socio GAS TT
Messaggi: 26
Iscritto il: mercoledì 19 aprile 2017, 20:05
Nome: Adriano
Regione: Lombardia
Città: Brescia
Stato: Non connesso

Re: LED con luce fioca scheda illuminazione carrozza

Messaggio da iname1030 »

Ciao a tutti,
riprendo per aggiornamento.
Alla ricerca del componente "U1" con marcatura L2 (vedi foto nel post iniziale e successivi) ho contattato alcuni rivenditori di eBay ed a fronte di un paio di risposte uno di essi gentilmente mi risponde:
"Salve mi dispiace non ho disponibile il suo che è un Dual N-channel dual gate MOS-FET " BF1203 " sembra introvabile, a lei comunque interesa solo la scritta L2 il resto non conta sono codici di produzione. Link al foglio tecnico "https://www.nxp.com/docs/en/data-sheet/BF1203.pdf".
Altro parere sosteneva che non fosse il componente adatto ma tantè visto che cercandolo risulta fuori produzione ed esaurito già da diversi anni prima che il treno sia stato prodotto. A questo punto mi è stato suggerito di tentare di sostituire il LED spento anche perchè non essendoci nella scheda una resistenza per ogni LED, ma una comune a tutti, poteva essere plausibile che la luce fioca degli altri 3 LED fosse provocata da quello guasto. Sostituito il LED incriminato ora tutti si accendono regolarmente. Una bella cosa sarebbe stata sostituirlli tutti e 4 ed inserire una resistenza ad ognuno... ma i LED che sono dei 0603 sono fuori dalla mia portata ed è già "oltre" l'aiuto che mi è stato fornito nella sostituzione.
Bene ora il treno si illumina tutto (anche i macchinisti hanno l'illuminazione in cabina aggiunta con due decoder separati), ho rifatto almeno l' 80 per cento delle saldature assieme alla sostituzione di diversi cavi ed è quasi in arrivo la stampa con materiale idoneo dei prototipi dei ganci centrali e poi... dovrei riuscire a completare il rodaggio al motore del treno !

Torna a “COLLEGAMENTI ELETTRICI”